ASUS A8N-SLI+ELSA GLADIAC 743 GTx2 SLI 奮闘記

いや~、ここまで苦労するとは思いませんでした。
先週の木・金曜日の会社帰りに
TWO-TOP、Sofmapを回って、夢のnVIDIA SLI環境構築のため
パーツを買いそろえたのですが、
WindowsXPのインストも終了し、1枚差しのベンチも取り終わり
さて2枚差しして、SLI環境導入だなと思ったら、
コレがまた非常に大変でした。
接続等は完璧なのに、さっぱりSLIが有効にできない。
ドライバーの詳細画面で、「マルチGPUを有効にする」の
チェックボックスがまったく出てこない・・・。
ググってひたすら調べて、いろいろなドライバーを
インストしてみたけれど、さっぱり。
で、見つけた記事の中で、同じバージョンの
VGA BIOSじゃないとダメらしいということが判明。
まさか、ウチの2枚のVGAカードのBIOS Verは同じだろうと
思って、「画面」のプロパティ→「設定」
→「詳細設定」→「アダプタ」タブ→「BIOS情報」を
参照したところ・・・・
1枚目のVGAカードのBIOS Ver:43.02.16.00(TwoTopで購入)
2枚目のVGAカードのBIOS Ver:43.02.33.05(Sofmapで購入)
はいっ。違う━━━━ヽ(゚∀゚ )ノ━━━━!!!!
表の箱みてもまったく同じモデルなのにBIOS Verが違うってナンデスカ orz
それで今度はVGA BIOSの書き換え方法を
ひたすら検索・・・。
そしたらnvflash 5.13.を発見。
で、MS-DOSフロッピーで起動して
nvflash.exeを実行しようとしたら今度は
CWSDPMI.exeやdos4gw.exeも必要であることが判明。
これもググってひたすら調べて、なんとか入手。
nvflash --index=0 -b index0.rom(1枚目のVGA BIOSをファイル出力)
nvflash --index=1 -b index1.rom(2枚目のVGA BIOSをファイル出力)
→「-b」はファイル出力のスイッチ
以上の2行でBIOSのバックアップを完了。
2枚目のVGA BIOSの方が新しいので
2枚目のVGA BIOSファイルを1枚目のBIOS RAMに書き込み。
nvflash --index=0 index1.rom
→スイッチ指定なしだとファイルからVGA BIOS RAMに書き込む。
という風にして、書き込もうと思ったら
「Error: Board ID mismatch!」・・・・orz
で、nvflash.exeのコマンドラインオプションを
みるとDeviceID、SubsystemIDのmismatchを
無視して強制書き込みするのが
「-5 -6」であることが判明。
そこで、
nvflash --index=0 -5 -6 index1.rom
という風に指定して実行したけれど、
また「Error: Board ID mismatch!」・・・・orz
海外のサイトの記事も探しまくったところ
隠しオプションで「-4」を指定すると
Board IDを無視して書き込み出来ることが判明。
nvflash --index=0 -4 -5 -6 index1.rom
これで、無事書き込み成功!!!!!
再起動して、無事VGA BIOSが立ち上がるのを見て
一安心・・・・。
デスクトップまでたどり着いたところ、
右下のところに「SLI動作が可能です」みたいな
メッセージが出現。
そこで無事「マルチGPUを有効にする」のチェックボックスが
チェックできるようになっており、チェックして再起動後、
SLI環境が無事完了っと思った矢先、
nVIDIA公式最新ドライバー(66.93)やベータドライバー(67.66)だと
2回目に起動したときに必ずブルースクリーンが発生することが判明;;
これもまたいろいろ試した結果、ForceWare71.20で安定。
こうして、なんとかSLI環境整備が完了。
長かった・・・・ホント長かった・・・・。
今回、ググった先の記事によって非常に助けられたので
今後同じような事態に直面した人のために、
こうした形で残すことに致しました。
この件で質問等あればメール等でご連絡ください。